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For a successful proceeding please follow the instructions step by step!

If you need any assistance, please contact Testing Technologies’ customer care department:

Mr. Dirk Borowski, Vice President Customer Care
Phone: +493072619190
Email: eurocontrol-support@testingtech.com

1 REQUIREMENTS

Operating Systems: Microsoft Windows XP, Vista, Windows 7, Windows 8
Red Hat Enterprise Linux (GTK, x86-32, x86-64)
Fedora (GTK, x86-32, x86-64)
SUSE Linux (GTK, x86-32, x86-64)

Java 2 Platform (JDK):  Version J2SE 6.0 (1.6.x) - Download at
www.oracle.com/technetwork/java/javase/downloads/index.html

Memory: 2 GB (4 GB recommended)

Please note that we strongly recommend using the above Java JDK. With the OpenJDK/IcedTea for
Linux the TTworkbench license will not work correctly.

Reference ID and License File

Before you download VOTER binaries (EUROCONTROL VolP in ATM Test Suite), TTworkbench (the Test
Platform required to run VOTER) and TTsuite-VOTER (the adaptation required to run VOTER), please
make sure you have received a valid Reference ID and a license file. Otherwise please contact our sales
team at eurocontrol-support@testingtech.com.

2 DOWNLOAD

Step1 Go to Testing Technologies’ download portal www.testingtech.com/support/downloads.php.

Step 2 Select the latest version of TTworkbench (Express, Basic or Professional) for your platform.
Step3 Enter your Download Reference ID (valid for TTworkbench, TTsuite-VOTER & VOTER binaries).
Step4 Download the file and save it in your favored directory.

Please note: With the Linux version of Microsoft Internet Explorer, the browser saves the
Jar file as .zip. Just rename it back to .jar.
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Step 5

Go to Testing Technologies’ download portal www.testingtech.com/support/downloads.php.

Repeat steps 2-4 to download TTsuite-VOTER (TTsuite-VOTER_xxx_archived-site.zip).

Step6 Got to the EUROCONTROL download portal
www.testingtech.com/support/partner/EUROCONTROL/download portal.php.
Repeat steps 2-4 to download VOTER (VOTER_xxx.zip).

Step 7 Save the license file license.dat in your favored directory.

Step 8 Optional: If you need to execute the test cases *_COS1, please download a jpacp installer

from a reliable source.

3 INSTALLATION

3.1 TTworkbench

Step 1
Windows Platform:

Double click on TTworkbench-xxx-installer.exe
(to be found on desktop or selected directory).

Linux Platform:

Use command line
java-jar TTworkbench-xxx-installer.jar

Step 2
Follow the pop up installation wizard.

On request, browse for the valid license file
license.dat, already saved in your favored
directory.

(VOTER Test Suite and TTworkbench require a
valid license file for execution, which was sent
to you by mail.)

Step 3

Start TTworkbench from created desktop icon
or menu entry.

% » Dk Borowski » Downdosds » | 43 | Downicods durchsucher P

Date  Besrbeten Ansicht Bares T
Organizeren »  InBibbothek sufnchmen Frigebenfur v Grennen  Never Ordner -0 e

5% Favorten
i Offentich $ ThworkbenchProfessions-win32-v12 instalerre 1201
B Desitop VB in ATM 101 archived-ctesip
& Downlosds
4 Zuktzt besucht
5 Zukett geincest

4 Bbbotheken
1% Computer
@ Netmwerk

R

2 slemente A Computer

e
F ] IzPack - Installation of TTworkbenchProfessiona

A license file is needed to operate TTworkbench. Please save the one you received from
Testing Technalogies in a convenient location and select it using the Browse buttan,

This step is optional. I you skip it now, please make sure to copy your license. dat later
to TTwaorkbench's installation Folder.

License file:

(license. dat) |license.dat -

Browse...

After installation TTworkbench can be initialized ko spesd up the first start, The resulting
cache data will be stored in the 'configuration’ subfolder.
Initialize after installation

Select a workspace

TTworkbench Professional stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Step 4 Workspace:  Crworkspace v | Browse.
[T Use this as the default and do not ask again
Start a new workspace by accepting the default
workspace location on request or choose an
existing one.
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3.2 VOTER Test Suite

Step 5

In the TTworkbench menu, click on menu item
Help - Install New Software...

Step 6
Click Add... = Archive.

Choose the downloaded installation file
TTsuite-VOTER_xxx_archived-site.zip.

Click the check box with Test Suites,
press Next - Finish.

Accept the terms of license agreements.
Finish and confirm to restart TTworkbench.

Step 7

After restart, please import the installed Test Suite.

Close the welcome tab. In the project view, just
click on the right mouse button, go to menu:

File > Import > TTCN-3 > TTCN-3 Test Solution
Projects > Select the installed Test Suite - Finish.

Find further details in the built-in Users Guide:

Help - Help Contents - Testing Tech TTsuite-VOTER.

Step 8

-, orkbench Professions

File Edit Navigate Search Project Refactoring Run Window [Help

[mithe | @ i~ iR @ Welcome
1% TTCN-3 Projects &3 =g (@) Help Contents
AEEE @ Search
Dynamic Help
Key Assist... Ctrk+ Shift+L

Tips and Tricks...
Cheat Sheets..

Certificates...
Verify Certificate Integrity
Check for Updates

Install New Software...

About TTworkbench Professional

Available Software

Select a site or enter the location of a site.

Work with:  type or select a site - Add...

Find more software by working with the 'Available Software Sites' preferences.
type filter text
Name Version

[[] @ Thereis no site selected.

Details

Show only the latest versions of available software [ Hide items that are already installed

Group items by category What is already installed?

Contact all update sites during install to find required software

®

MNext > Finish

Select
Import the TTCN-3 Test Solution Project(s) into workspace.

Select an import source:

type filter text

> = General
b = CVS
[» [ Plug-in Development
[ (= Run/Debug
[» = Team
a4 (= TTCN-3
@ TTCM-3 Example Projects...
% TTCN-3 Test Selution Projects...|

®

o

File

Edit Mavigate Search Proj ctoring  Run  Window [Help

[ | B Q- @R (@ Welcome
1% TTCN-3 Projects (3 =8 (?) Help Contents
 BE" % Search
Dynamic Help
Key Assist... CtrlShiftL

Tips and Tricks...
Cheat Sheets.

Certificates...

Verify Certificate Integrity
Check for Updates
Install New Software...

About TTworkbench Professional

Unzip the VOTER_xxx.zip file. Copy the tten3build folder. Open the VOTER folder in the Package
Explorer (TTCN-3 Development Perspective). Paste the ttcn3folder into the root of the VOTER folder.
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Step 9 (Optional)

If you need to execute the test cases *_COS1, please install jpacp with the downloaded installer.

Further details about installation you can find in the integrated Users Guide.
Click on: Help > Help Contents - Testing Tech TTsuite-VOTER.

4 RUNNING MY FIRSTTEST CASE

Step 1

Open the VOTER_xxx folder in the Package
Explorer (TTCN-3 Development Perspective).

Step 2

Open the folder Testcases and double click on the

test campaign loader file

xxx.clf (with the icon .E] ).

(The perspective will automatically switch into
the TTCN-3 Execution Management.)

Step 3

Start your IUT.

Step 4

Click on the test campaign name to edit
the parameters in the Parameter View
(below Management View).

For configuration details please refer to
Chapter “5. Parameterization”.

Parameters are configured with default value.
Please use MBS (Message Building System) to
change the values.

=T TTCN-3 Projects &7 =B
@ Bg
4 = VOTER;
[ [f:—,T- tten3
[» [~ .settings

I+ = audio_files
4 [ Testcases
B = VC5_CLFs
.B GRS_Radio_DDC_Testcases.clf
.a GR5_Radio_Interface_Testcases.clf
.a GRS_Radio_L5M_Testcases.clf
.a REC_Recorder_Interface_Testcases.clf
o | RRCE Testcases.cl
<& | VC5_Radio_DDC_Testcases.clf
< | VC5_Radio_Interface_Testcases,clf
| VCS_Radio_LSM_Testcases.clf
| VC5_Radio_RRCE_Testcases.clf
<& | VCS_Telephony Interface_Testcases.clf
| VCS_Telephony_OVR_Testcases.clf
|» [ Testcases_Performance_Measurements
[ = t3plugins
i = tten3build
.«classpath
Jproject
E eurccontrol-cert.pl2
smime.properties
taconfig.xml
tls.properties

= xralxsd

= Management View 1 = Meta Campaign View. = 057 Test Dota View 22 [7) Dump View & Conscle
K m[Em| &8 7| B @~ | Dpected TICNS Templste

Hame Value

&
1 CONTINE
1 CONTINUE
1 CONTINE
1 CONTINUE
1 CONTINE
1 CONTINUE
1 CONTINE
1 conmnuE
1 CONTINE
1 conTINE
1 CONTINE
1 CONTINE
1 CONTINUE

- . TTCN-3 Graphica Logging B TTCN-3 Tertuel Logging 1
@ TC RIS oo Mend enil. | (@ TTCN-2 GaphicaLogging & TIN-3 Textun Logging
ek W ebewet 0

Hone: 0 *Pazs: o Inconc: 0 Fak L] *Emor: o pe e tnt

Time Message

£3, 1 Properties View

e
«oP Open Message Building System
o Feset To Defoult

Reset Al To Defacit
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Step 5

Execution

Select one test case by single click and press the Execute tests button % .
I vcstion g Tvenc s T .

File Edit Navigate Search Project Refactoring Run Window Help

wild LIS O R g H-F-%e-o- B & TTCN-2Dev..
(=] 80 Meta Campaign = O (£R Test Data £3 ] Dump| B Console| S ua@¢ & -0
XN E| BRI EE BB O 7 aches [12:0045.861 match Response: min_Response -
[ type fitter text |
Expected TTCN-3 Template Data
TES‘@CE:RS Radio Interface Testcases_burx_convert = INCONé s ot [pefite et I
P TC_RAD SIP sessl o 1 conTn || Name Value “ Name Value *
@ TC_RAD_SIP sess2 1 CONTIM o Response H 4 o Response E]
P TC_RAD_SIP_sess3 1 CONTIN W statusline 4 W statusline
P TC_RAD_SIP sessd 1 CONTIN < sipVersion  SIP/2.0 & [sipVersion
@ TC_RAD_SIP sesss 1 CONTIN @ statusCode 180 ¢
P TC_RAD_SIP sess 1 CONTIN < reasonPhrase 7 & o
@ TC_RAD_SIP sess? 1 CONTIM & msgHeader 4 B m
P TC_RAD_SIP sess 1 CONTIN o accept - ¥ [ press 2 tofows)
@ TC_RAD_SIP sessd 1 CONTIM B acceptincod * o acceptEncod omit
P TC_RAD_SIP sessl0 1 CONTIN a acceptlangu * o acceptlangu omit
P TC_RAD_SIP sessll 1 CONTIM W alertinfo o alertinfo  omit
@ TC_RAD_SIP INV_Mand Headl 1 CONTIN o allow - o allow omit
P TC_RAD_SIP INV_Mand_Head2 1 CONTIN i authenticatic o authenticatic omit
D T . cm = W authorizatior * ¥ authorizatior omit
o calld 4 o calld
¥ fieldNam CALLID E A ¥ fieldNam CALL ID E A

1 Parameters £2 . [ Test Adapter Parameters | 5 Properties|  — O

EFEE TTCN-3 Graphical Logging 53 ) TTCN-3 Textual Logging| EJ Log Stack| BEEE LI E ]
[ type fitter text | MTC SYSTEM Client
Name Value =
& General_Settings @ 13:00:44 245 tc_syne(0.29) -
@ PXETS ACTION_BOX TIER 20000 1300:44.247 [T senrsyncClientsTimed: ync server now starting JEST BODY synchronization ., *=**
< SIP_General_Settings
& SipTransport 13:00:44 247 S te_syne(t20)
| © PXSPTRANSPORT .uDp SETEmED S
& sipRegistration
send INVITE Request
@ PX_SIP_CLIENT_REGISTRATION false 13:00:45.161 udnlﬂl‘ ‘Sm
K :x,:ESA‘\;REsxsTRAnoN 100" BT wdpl] ‘ receive Response _‘“p
< sipHeaderfields .
receive Response
@ PX_MAX_FORWARDS 70 BT udp0} sip
< invalidHeaderValues 13:00146.212 ass > Expected message received.”
< PXINVALID EVENT HEADER  "invalid event” AT
B . . se cquet |
< PXINVALID_REASON_HEADER  invalid reason (ETHEED dp0] ‘ P
< PXINVALID_SUBSCRIPTION STAT “invalid subscri.. 13:00:46324 e send SyncCmd e
< cinTimere 2
o [aloE® 4 @

Please find further details under Help > Help Contents > Testing Tech TTsuite-VOTER.

4.1 Analysis

When you click on the TTCN-3 Graphical Logging tab you see the results of the execution as graphical

output.

A single click on a “send” message arrow provides further details of the TTCN-3 template representation
in the Test Data View. Double click on “send” and “receive” arrows for a coding in the Dump View.

A single click on a “match” or “mismatch” box shows you the received message compared to the
expected TTCN-3 template. Mismatched values are marked red.

- - = |
File Edt Navigate Search Project Refactoring Run Window Help
e Biavier Gl it i H@
< Management View 71 (% Mata Campaign View “ O & Test Data View 55 [] Dump View © Console L Wy & 70
w5 &, o 7] B @~ 7| Epected TICN3 Template Data
= Nome value - | Name vae -
7 ¥ Response L ¥ Response
TestCase Funs  INCONCFAR Action Retnes e e
© VolP_in ATM Demo. 5 sipVession SIP/20 5 spVession SIP/20
@ TCRAD_SP sessd 1 CONTINUE 0
P 11:16593% £ reasonPhrase ? £ reasonPhrase Not Acceptable Here
@ TCRAD_SP_BYE_Mend Headl 1 CONTINUE ) = & msgHesder W msgHesder
o 111719277 o sccept o accept omit
o TCTELIC MonCalll 1 CONTINUE o ¥ scceptncoding W acceptincoding omit
@ 11757460 o acceptlanguage o acceptlanguage omit
o TC.TEL SP_Non Yot Hescl L conme o briir o e o
o 111828140 o sliow o allow omit
@ TCNCS_S0P_attrib_negotiationl 1 CONTINUE 0 Pl o mithenticationinin . s o mshenticationinfn omit =
‘ - ! (BT Guphicatoasing £, D TTCN-3 Tetul Loggng | & Progres &R
wTotst 6 sbected 6 | 100% -~ & & Y »°
T e e T s o | Result
e o
Management e ring i bodr..
_g 1 Pacameters View [ Properties View m =0 send INVITE_Request An aI ySer
View -
11arsases 5 e
famnite ol = 114759656 I Eimat [ e
e — - R response: aw Response
§ PX.R2S JEEP_ALNE PERIOD Al arssesn L S———
¢ PURS P ANEMATRUR 10 narsasss S ——
> dsConfiguation
& »PXETS NCS 1| wsednfoi=(  defaultUser := “defauitl’, e 11:17:59.673 [EERSEER] Response: mw_Response
o >PX_ETS GRS { grsType:= ¢ Transceives, name:= “defauitl’, do
o >PIETS GATEWAY { usernfo:s | defaultUser:= “defaultl’, emerge a7 P emome wm Remone
¥ >snConfiguration 114759709 P (—————————— 5
@ PX_SP_Radio_Session_Limit_ Max 2 'y -
(P Rasi Sesion.| 1arsen T —
o PXSUTVGS { userdnfo:={ defaultUser:= “defaultl’, emerge e s
o >PX_SUT_GRS. { grsType:= « Tansceiver, name = “defaulti’, do 114809473 [t e
5 >sipPacamete e
= ik ey o
ey S nasonane ; ‘ e p— I
Test # PX_DELTA REGISTRATION 100" . o =

£ >splimer

Parametrization

Graphical
Online Logging
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4.2 Saving Configurations and Test Results

The current executed run of test cases can be saved 2 TICN3 recton Management Tt P A

File Edit Navigste Search Project Refactoring Run Window Help

in a *.tlz file. Press the export button and select CHEIR g B Heeg-
" " o I ment View F Meta Campaign View =8
Export Log” in the Management View. Mt & S e Conprpes AR G AT T
type filter text Export Test Campaign
The generated *.tlz file (with the icon <) contains e Rume | MCONGTALAakn _ Rel PRI
the current configuration (CLF) and the executed o T RA0.57 oV Mo e 1 commue D rmm
log traces. vow 6 sbeane 0
" None: 0 ®Pass: o ~Incone: 0 = Fail: o = Error: 0

@ 01 it W T

File Edit Navigste Search Project Refactoring Run Window Help

This file can be imported for reviewing. Press the O HEIR Q- A (BB -
import button and select “Import Log”. e, o Mtz Cmpian view] -0
X8| ER SE)E-QLBO-
. . type filter text Import Test Campaign
To run configured test cases again, please press the Tecoe foms INCONC/PAILAGton | Import TestSession
i H olP_in emeo Import Lo
import button and select “Import Session”. s — e
@ TC_RAD_SIP_BVE_Mand_Headl 1 CONTINUE 0 R_GW _SIP_R_U...
aTotal: 6 ® Executed: o
= None: 0 ®Pass: o ~Incone: 0 = Fail: o = Error: 0
= —|
In order to generate a test report, use this button. [Create a test report for the executed test suite or an existing log file

For further details about execution and savings please refer to the integrated Users Guide, Chapter
“Using TTworkbench TTman”. Click Help > Help Contents - Testing Tech TTsuite-VOTER.

5 CONFIGURATION

Please configure your VOTER Test Suite according to
the protocol and your local settings.

You can use our MBS (Message Building System)
to ease it up.

In the Parameter View of the Execution Management
you find different parameters to change the settings
for your individual test configuration.

Please click on the right mouse button over the
parameter view to open Message Building System.

You can access the single parameter and the attributes of single fields. After finishing, just click on OK to
save the change. The changed parameters are called by the test system during runtime. You can run
your test campaign with the new configuration at once without recompilation of your test cases.

You can find further details about Test Suite Properties under TTworkbench menu
Help = Help Contents - Testing Tech TTsuite-VOTER.
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6 DETAILS

6.1 Core Language Editor (CL Editor)

Each TTCN-3 file is view- and editable by double clicking in the CL Editor. As shown in Step 1 of
“4. Running My First Test Case” you find the TTCN-3 source code (*.ttcn3) in folder ttcn3.

After opening the files, the source code will be syntactically checked and highlighted. In addition, an
outline will be generated automatically and the go-to-declaration feature will be enabled.

" TTCN-3 Development - VelP_in ATM_Test_Suite_101/ter3/R_GW_SP_R_UA/R_GW_SB_R_UA_Testcases tiend - TTwarkbench Professionsl SR =)
Fle fdt Sawce Mavigste Sewch Project Refoctorng Fun Window Help

cHE R PEA G- s (DEED S e = 9
D TTCH-3 Projects T T B ¥ volP_in ATM Testcasesnicnd | ) RUGWLSIP R UA Testcasesttend (1 = B1[8= outiing [N A=

group ¥alid { - @ RGW_SP R_UA Testeases
group SIE, 1 atons

n =8

z import declratio

(W]

& TCRAD SP sesc?

& TC_RAD_SIP sessl

o TCRAD S sessd
D,

1_omn

TTCN-3 Compiler/
Validate Buttons

testcase TCHAD ST seasi ()
runs on TestHanage: system TestIncerface |
var v_ptce i= Sipc te ("Client”);

Outline

140,
= SipUsl (FX_SUT ¢
PX_suT

somatn) )y

£_secverSyncHClientsindStep(1, {c_prDome, ¢_tbDone, ¢_poDonel):

testa

C_RAD_SIF_sess:
Pager

m_un

) s — - TTCN-3
" 2 Problems 1 &) Console] B Graph Module Dependencies| [ TTCN-3 Declarstions | @ T30oc 4" Sewch ) ~&  CL Editor
5 0 items
Pro ject View B s Besciption . [——— Location _Type

B project
] tacontia_demosmi

itable: Smatlnset | 105:55

6.2 TTthree (TTCN-3 Compiler)

For recompiling all TTCN-3 files, please open the main module (with the icon [11) in the CL Editor by
double click. Press the Rebuild button [, . After recompilation follow Step 2 of “4. Running My First
Test Case”.

NOTE! Compilation is only necessary if some test cases are changed or some new one is created.
Otherwise, the generated *.jar files from TTCN-3 source are already available for execution.

6.3 TTman (Test Execution Management)

In order to execute test cases and configure parameters, the CLF has to be loaded into the Test
Execution Management.

In Testcases and Testcases_Performance_Measurements, you will find at least one CLF file (with the
icong ). It contains all the test cases, which are organized in specific group structures.

NOTE! You are able to execute all test cases only if you have purchased the test suite. With your
evaluation license file you may only run some test cases for evaluation.

Further details you can find in the integrated Users Guide, Chapters “Using TTworkbench CL Editor”,

“Using TTworkbench TTthree” and “Using TTworkbench TTman”. Click on Help > Help Contents >
Testing Tech TTworkbench Users Guide.
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7/ APPENDIX

Acronyms

CL Editor Core Language Editor oS Operating System
CLF Campaign Loader File SUT System Under Test
IuT Implementation Under Test TLZ Test Logging Zip File
MBS Message Building System

Notes

This document is subject to change without notice.
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